+ Reply to Thread
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By K_Note72

Thread: Revo 2.5R engine won't start AT ALL, any help?

  1. #1
    RC Set Designer
    K_Note72 started this thread.
    K_Note72's Avatar
    Join Date
    Jul 2011
    Location
    IntheBoonies, Orygun
    Posts
    548
    Country
    United States
    Mentioned
    1 Post(s)
    Add K_Note72 on Facebook Visit K_Note72's Youtube Channel

    Revo 2.5R engine won't start AT ALL, any help?

    Seeing as how I'm all electric and have only so much as run a nitro a couple times, I could really use some help here!

    So this memorial day weekend my sister and brother-in-law came down to visit, and SURPRISE SURPRISE he brings his Revo 2.5. For starters, it looks like it's seen better days, the reverse module he tells me kept burning out and the rats in his garage had their way with the shift servo wire. He tells me about how he can't get it to run at all and doesn't have the time to figure it out, so I was appointed the task of either getting it going or parting out and selling it. He even mentioned that he already got a Rustler to replace it, so he's clearly given up on it. I'd rather say I've given my all before I give up and sell it.

    THE BASHMONKEY ACCEPTS THE TASK

    First order of duty is check the ez-start and glow plug. EZ-start: Check. Glow plug: Nada. Check the wire, rats had their way with that too. 2 days later, replacement wire arrives & gets installed. Glow plug: Check. Still won't start though. Visible air bubble in fuel line, doesn't move while cranking even while priming. Reset Hi/Low needles to factory: still nothing. Cleaned air filter: still nada.

    TIME TO PLAY OPERATION: ENGINE SURGERY

    Small can of air blast into carb: Brown gunk flies out and now carb is clear. Open up engine entirely, DEAR GOD SO MUCH BROWN GUNK!!! Clean off ALL engine parts and put em all back together (even made sure to taut all cooling head screws before tightening. Everything back together, crank it for a couple minutes and see fuel flowing in. My god it even started, idled for a minute but then died. Since then it's only come close to starting a few times.

    Any idea what I might've missed?


  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many



    Photobucket

    Click the Banner to come Check Out our Amazing RC Store!
    We Ship World-Wide!

    RCSparks Studio Approved!
     

  3. #2
    Banned
    Join Date
    Oct 2011
    Location
    Roermond Netherlands
    Posts
    801
    Country
    Netherlands
    Images
    17
    Mentioned
    4 Post(s)
    Check the fuel tank seal on the filler lid, might be leaking and not holding pressure. also how old is the engine and the fuel ? sound like the motor was not taken care of too well in the past with all the gunk in it. also try using a dedicated glow plug igniter and not the one that is used with the ez start system . I have ran into problems in the past many times with the glow plug ez start igniter, I use a good glow plug igniter that has wires that I attach to a hobby 1.5v starting battery ( kinda looks like a lantern battery) Also you can try a hotter glow plug to help it run better. This motor may have also been over heated and can lose compression when getting to operating temp and then shut down. Nitro motors are finiky and watching the head temp is a must during tuning. Also check the air filter and clean if needed. Did you also clean out the fuel inlet line at the carb ? might be gunked up. If the fuel is more than a year old repleace it , Traxxas makes a great 33% nitro fuel that burns clean and makes starting easier along with more power. Also use after run oil to help keep the gunk build up to a minimum and bearing lubed. It sound like you also covered some of the other area's I would check already. If no luck then I would say the motor is garbage and look into a traxxas 3.3 motor for replacement at the same cost of the 2.5 motor or due the conversion to electric for about the same price. Hope anything I mentioned helps you out. Cheers.

    here is the type of battery and igniter I use.



    Last edited by crawlerdave; 05-30-13 at 1:13 AM.

  4. #3
    RC Set Designer
    K_Note72 started this thread.
    K_Note72's Avatar
    Join Date
    Jul 2011
    Location
    IntheBoonies, Orygun
    Posts
    548
    Country
    United States
    Mentioned
    1 Post(s)
    Add K_Note72 on Facebook Visit K_Note72's Youtube Channel
    Quote Originally Posted by crawlerdave View Post
    Check the fuel tank seal on the filler lid, might be leaking and not holding pressure. also how old is the engine and the fuel ? sound like the motor was not taken care of too well in the past with all the gunk in it. also try using a dedicated glow plug igniter and not the one that is used with the ez start system . I have ran into problems in the past many times with the glow plug ez start igniter, I use a good glow plug igniter that has wires that I attach to a hobby 1.5v starting battery ( kinda looks like a lantern battery) Also you can try a hotter glow plug to help it run better. This motor may have also been over heated and can lose compression when getting to operating temp and then shut down. Nitro motors are finiky and watching the head temp is a must during tuning. Also check the air filter and clean if needed. Did you also clean out the fuel inlet line at the carb ? might be gunked up. If the fuel is more than a year old repleace it , Traxxas makes a great 33% nitro fuel that burns clean and makes starting easier along with more power. Also use after run oil to help keep the gunk build up to a minimum and bearing lubed. It sound like you also covered some of the other area's I would check already. If no luck then I would say the motor is garbage and look into a traxxas 3.3 motor for replacement at the same cost of the 2.5 motor or due the conversion to electric for about the same price. Hope anything I mentioned helps you out. Cheers.

    here is the type of battery and igniter I use.

    I've checked all those areas, but I got one problem fixed then ran into another. It helps if the motor and roller clutch are set to spin the RIGHT way (boner on my part). Cranked it for a minute, almost had liftoff, then the EZ-start STOPS IGNITING THE GLOW PLUG. 3 brand new glow plugs, ez-start won't ignite any of em. I swear this EZ-start is a total POS, it shuts off before I get anywhere and then goes and stops working the glow plug. If I can get this engine to run and prove it's do-able, this EZ-start gets trashed & swapped for a reliable plug igniter and pull start

    crawlerdave likes this.

  5. #4
    Banned
    Join Date
    Oct 2011
    Location
    Roermond Netherlands
    Posts
    801
    Country
    Netherlands
    Images
    17
    Mentioned
    4 Post(s)
    I use a roto start system that I use with a cordless drill to start the engine along with the battery and igniter below in the pics and have no problems starting it. yes the ez start is crap..lol.

    Quote Originally Posted by K_Note72 View Post
    I've checked all those areas, but I got one problem fixed then ran into another. It helps if the motor and roller clutch are set to spin the RIGHT way (boner on my part). Cranked it for a minute, almost had liftoff, then the EZ-start STOPS IGNITING THE GLOW PLUG. 3 brand new glow plugs, ez-start won't ignite any of em. I swear this EZ-start is a total POS, it shuts off before I get anywhere and then goes and stops working the glow plug. If I can get this engine to run and prove it's do-able, this EZ-start gets trashed & swapped for a reliable plug igniter and pull start



  6. #5
    RC Set Designer
    K_Note72 started this thread.
    K_Note72's Avatar
    Join Date
    Jul 2011
    Location
    IntheBoonies, Orygun
    Posts
    548
    Country
    United States
    Mentioned
    1 Post(s)
    Add K_Note72 on Facebook Visit K_Note72's Youtube Channel
    Quote Originally Posted by crawlerdave View Post
    I use a roto start system that I use with a cordless drill to start the engine along with the battery and igniter below in the pics and have no problems starting it. yes the ez start is crap..lol.
    Seeing as how there's aftermarket roto start sets that'll fit the 2.5r and the roto on my cousin's savage makes things easy for him, if I can prove this engine's gonna run I'll put one on it


  7. #6
    Studio Forums Elite

    hvydingo's Avatar
    Join Date
    Aug 2012
    Location
    Vancleave MS.
    Posts
    1,032
    Country
    United States
    Mentioned
    8 Post(s)
    Add hvydingo on Facebook Visit hvydingo's Youtube Channel
    Pull the high speed and low speed needles completely out and turn it over to flush the carb out.Change the fuel line out sounds to me it was stored with fuel in it.Use a seperate hand held igniter with a new 3232x glow plug,put fresh fuel in it,and put some into the carb and fire it up.It should fire right up,if the motor is shot it will fire up cold then die out about 1/4-1/2 tank through it.If you think the ez start is garbage imagine how many blisters you would have if you had a pullstart plus a sore elbow.

    [IMG]rcsparkssignature-forhvydingo_zps7bab63e6[/IMG]

  8. #7
    RC Set Designer
    K_Note72 started this thread.
    K_Note72's Avatar
    Join Date
    Jul 2011
    Location
    IntheBoonies, Orygun
    Posts
    548
    Country
    United States
    Mentioned
    1 Post(s)
    Add K_Note72 on Facebook Visit K_Note72's Youtube Channel
    Quote Originally Posted by hvydingo View Post
    Pull the high speed and low speed needles completely out and turn it over to flush the carb out.Change the fuel line out sounds to me it was stored with fuel in it.Use a seperate hand held igniter with a new 3232x glow plug,put fresh fuel in it,and put some into the carb and fire it up.It should fire right up,if the motor is shot it will fire up cold then die out about 1/4-1/2 tank through it.If you think the ez start is garbage imagine how many blisters you would have if you had a pullstart plus a sore elbow.
    Already did the thing with the needles, i know the carb is clear cuz i've cranked with the air filter of and seen the fuel squirting in. And i know its gettingfuel in the engine too cuz it hydro-locked a couple times and when i cleared it i got the nitro dripping from the pipe. For now i know the glow plug driver in the ez-start burned out, the GP light doesnt turn on just the motor light. We're havin a family get-together tomorrow and my cousin's bringin his savage so ill have use of a GP driver.

    With how many finicky yard tools i've had to deal with, im the king of the pull start! If not then i could put on an aftermarket roto start, my cousin has it on his savage and when you pop it onto a drill its the easiest thing in the world


  9. #8
    RC Set Designer
    K_Note72 started this thread.
    K_Note72's Avatar
    Join Date
    Jul 2011
    Location
    IntheBoonies, Orygun
    Posts
    548
    Country
    United States
    Mentioned
    1 Post(s)
    Add K_Note72 on Facebook Visit K_Note72's Youtube Channel
    Yesterday I finally got a dedicated glow starter, so I found a fresh C battery and gave it a try

    I finally got the thing running

    Had to cut it off quick cuz I remembered I was still in the garage and exhaust was filling up the room quick. And then on the later starts outside, the starter motor starts free spinning (sounds like the roller clutch going out). It'll engage on and off, but when I prime it and start building compression (getting very close to starting) it starts slipping again. Looked it up, $20 F!@%ing bucks for a new roller clutch!

    At this point, it runs but it's just one problem after another. I know that to be fair the EZ-Start was 75% of the problem (even after the engine was cleaned & good to go), but this thing is really killing all interest I HAD in nitro


  10. #9
    Studio Forums Elite

    Juddp's Avatar
    Join Date
    Oct 2012
    Location
    on earth
    Posts
    671
    Country
    United States
    Images
    2
    Mentioned
    6 Post(s)
    Add Juddp on Facebook Visit Juddp's Youtube Channel
    Quote Originally Posted by K_Note72 View Post
    Yesterday I finally got a dedicated glow starter, so I found a fresh C battery and gave it a try

    I finally got the thing running

    Had to cut it off quick cuz I remembered I was still in the garage and exhaust was filling up the room quick. And then on the later starts outside, the starter motor starts free spinning (sounds like the roller clutch going out). It'll engage on and off, but when I prime it and start building compression (getting very close to starting) it starts slipping again. Looked it up, $20 F!@%ing bucks for a new roller clutch!

    At this point, it runs but it's just one problem after another. I know that to be fair the EZ-Start was 75% of the problem (even after the engine was cleaned & good to go), but this thing is really killing all interest I HAD in nitro
    I had the same problems with my 3.3 tmaxx that i got used and cheep. I think i even did everything you did, and every time i ran it there was always something else wrong with it! After i used up all my nitro i said **** it and converted it to electric. now its a beast! but i do miss the sound and smell of nitro.


  11. #10
    RC Set Designer
    K_Note72 started this thread.
    K_Note72's Avatar
    Join Date
    Jul 2011
    Location
    IntheBoonies, Orygun
    Posts
    548
    Country
    United States
    Mentioned
    1 Post(s)
    Add K_Note72 on Facebook Visit K_Note72's Youtube Channel
    Quote Originally Posted by Juddp View Post
    I had the same problems with my 3.3 tmaxx that i got used and cheep. I think i even did everything you did, and every time i ran it there was always something else wrong with it! After i used up all my nitro i said **** it and converted it to electric. now its a beast! but i do miss the sound and smell of nitro.
    Well in my case he still has a gallon and a half left.........4th of july sideshow? Wouldn't be a bad idea, considering it probably won't be used by the revo

    Nitro looks cool and all, but especially in my case it's more trouble than it's worth. When I first started in rc I was considering a nitro, good thing I went with electric instead. If I do get something other than electric its gonna be a gasser, no finicky engines and tedious tuning


+ Reply to Thread

Similar Threads

  1. My Nitro Engine Won't Start
    By pakman1977 in forum Nitro
    Replies: 2
    Last Post: 08-01-13, 1:45 PM
  2. Associated Reedy .21 VS Pull Start Nitro Engine
    By JK_Wrangler in forum Nitro
    Replies: 1
    Last Post: 06-16-13, 7:47 PM
  3. where to start..
    By dirtracer51 in forum Scale Truck Chat
    Replies: 5
    Last Post: 04-26-12, 3:53 PM
  4. Replies: 5
    Last Post: 04-21-12, 11:51 AM
  5. Engine sounds how can i make my rc have a engine sound?
    By LetsGoMuddin in forum RC Chat, Tutorials, Ideas, Requests, Etc
    Replies: 10
    Last Post: 10-06-11, 4:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts


About this Forum

    The RCSparks Studio is a community designed to promote the Radio Control Hobby and RC ADDiCTS from all around the World!

Follow us on

Twitter Facebook youtube RSS Feed