1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Motor smell.

Discussion in 'Trail Truck Electronics' started by Bluebox, Feb 16, 2013.

  1. Bluebox

    Bluebox New Member

    Joined:
    Aug 20, 2012
    Messages:
    98
    Likes Received:
    0
    I was using my wraith, and attempted to crawl up the stairs. I tried to go up the final step in the corner, then I noticed I was fully accelerating and my truck was not moving. I lifted up my truck to place it again because I thought I was using a bad line, then smelt a really bad smell. I placed down my truck, and gave it a little acceleration. It sounded kind of like the slipper clutch. I took it inside and let it rest for I while. I then took it outside and crawled around for about 5 minutes. The "slipper clutch sound" is really faint now. It it safe to keep using the motor? Or should I replace it?
     
  2. Alan687

    Alan687 New Member

    Joined:
    Oct 13, 2012
    Messages:
    65
    Likes Received:
    0
    the really bad smell from a motor is the sign that it is burnt out as for the strange sound it is possible that something got lodged in your motor (this would be why it burnt out) then when you drove it after it worked its way out but the damage is already done, i would recommended replacing the motor

    :tttt:
     
  3. Dribble

    Dribble A Friendly Enforcer
    Staff Member SUPER MODERATOR

    Joined:
    Apr 28, 2011
    Messages:
    3,465
    Likes Received:
    23
    Motor is burnt out. Thing is with the wraith this is a very normal thing that happens with a lot of them and I see it happening all the time still. Stock Wraith motor burns out very easily.

    I would replace and while you have it apart check to make sure everything is good inside the tranny from that sound.
     
  4. Bluebox

    Bluebox New Member

    Joined:
    Aug 20, 2012
    Messages:
    98
    Likes Received:
    0
    Damn. Oh well, it happens.
     
  5. Jhvaron

    Jhvaron New Member

    Joined:
    Oct 24, 2011
    Messages:
    154
    Likes Received:
    0
    Well, my son is one of the afectaded with this epidemy. he was going up a sand hill in the beach and gat stock and sudently the engine start smoking and go death
     
  6. sgtlunchbox2

    sgtlunchbox2 New Member

    Joined:
    Jul 30, 2012
    Messages:
    70
    Likes Received:
    0
    Same is happening to my wraith but the esc smells bad. Plus the motor would get so hot it would boil water off of it. And now when i hook my battery u the esc wouldnt beep. I binded the radio and reciever and now it does beep. now though everytime i bind the radio system the radio says it binds and after i power it all back up the radio isnt linked with the reciever what is wrong!!
     
  7. drzoo2

    drzoo2 Well-Known Member

    Joined:
    Dec 2, 2012
    Messages:
    818
    Likes Received:
    238
    Unplug everything from the receiver. Get an external battery to power it. Re-bind. Turn off. Turn on.

    Is it still bound to your radio now?

    btw, if your ESC smells funny, It's dead, dying, or will be very shortly. Most likely the cause of your binding issue.

    Your motor should never get that hot. You may have damaged the magnets.
     
    #7 drzoo2, Mar 5, 2013
    Last edited: Mar 5, 2013