1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bec issues

Discussion in 'Studio Discussions' started by Kobusp, Oct 26, 2014.

  1. Kobusp
    Instant PM

    Kobusp New Member

    Joined:
    Oct 26, 2014
    Messages:
    4
    Likes Received:
    0
    Hi there
    Hope you can help. I live in South Africa. Bought a Wraith. Installed a Vanguard esc and vanguard 2900 kv motor.

    It runs fine as is. As soon as I install a bec it stutters if you apply full throttle. Remove the bec and all is fine. I tried a cc bec as well as a radio shack bec.

    I did all the steps as the diagram shows.

    Help please
    Kobus
     
  2. jaloos
    Instant PM

    jaloos Mod, Staff Member and Ghetto Fabricator
    MODERATOR

    Joined:
    Oct 14, 2012
    Messages:
    2,959
    Media:
    133
    Likes Received:
    185
    Without more information and perhaps some pics of what you are attempting to do it is hard to impossible to help with the little information you have provided.
     
  3. Kobusp
    Instant PM

    Kobusp New Member

    Joined:
    Oct 26, 2014
    Messages:
    4
    Likes Received:
    0
    I am trying to get the BEC to work with my setup. What other info do you need?
     
  4. jaloos
    Instant PM

    jaloos Mod, Staff Member and Ghetto Fabricator
    MODERATOR

    Joined:
    Oct 14, 2012
    Messages:
    2,959
    Media:
    133
    Likes Received:
    185
    How is it being hooked up.
    Is it hooked up to power the servo only?
    Is it being connected to the receiver?
    Have you pulled the red wire from the esc to the receiver if you are hooking the bec to the receiver?
    What position on the receiver are you hooking it to if you are hooking it to the receiver?
    What diagram are you using?

    Never heard of a radio shack BEC ever what is it?

    What battery packs are you running?
    Are they Fully charged?
     
    #4 jaloos, Oct 26, 2014
    Last edited: Oct 26, 2014
  5. Kobusp
    Instant PM

    Kobusp New Member

    Joined:
    Oct 26, 2014
    Messages:
    4
    Likes Received:
    0
    Castle creations BEC diagram.
    Connected to the reciever
    I have pulled the red wire out where the esc connects to the reciever.
    I am using the battery channel on the reciever.
    Sorry about the name. It is a 6v 10 amp Radio South BEC.
    My battery packs are 2.2 turnigy 3s.
    Yes. The packs are fully charged
     
  6. jaloos
    Instant PM

    jaloos Mod, Staff Member and Ghetto Fabricator
    MODERATOR

    Joined:
    Oct 14, 2012
    Messages:
    2,959
    Media:
    133
    Likes Received:
    185
    If its the turnigy 2.2 3s packs that are only 20c you may be running into lack of current to power everything under full throttle
     
  7. Y2daT
    Instant PM

    Y2daT Over Powered RC
    ELiTE MEMBER

    Joined:
    Dec 25, 2013
    Messages:
    4,041
    Likes Received:
    1,064
    what I was thinking Jaloos . id say you want a minium of 80 amps constant . but id go more . a 4000 mah at 20C = 80 amps a 2200 mah @ 20C= 44 amps .
    hobby king has some nice batteries . I have the turinigy 5600 mah 50C-100C ... so 280 amps constant and 560 amps burst . this is a 2S battery . Turnigy nano-tech 5600mah 2S2P 50~100C Hardcase Lipo Pack (ROAR APPROVED)
    .
    to calculate the amp out put of any battery multiply the mah X .001 then that X the C rating ... so 5000 mah X.001 = 5.0 X 20C = 100 amps .
     
  8. Kobusp
    Instant PM

    Kobusp New Member

    Joined:
    Oct 26, 2014
    Messages:
    4
    Likes Received:
    0
    Hi jaloos. I can understand your point.

    Why will everything then run normal of the esc bec with red wire connected as soon as I disconnect the cc bec? If it was cogging at low speed, why only when the bec is connected?

    I have also tried a 60c 5000 mah battery and same thing!!

    HELP........
     
  9. Y2daT
    Instant PM

    Y2daT Over Powered RC
    ELiTE MEMBER

    Joined:
    Dec 25, 2013
    Messages:
    4,041
    Likes Received:
    1,064
    in that case there is another issue. that is 300Amps way more than enough juice .
    back to the bec connection. when you plug the bec into the rx you need to snip the red wire to the Esc . ( if this is how it runs Bad then you could reconnect the Esc as normal and make a bypass for the bec to run components like a servo. with out putting the power into the rx .
    another question is what voltage Bec ?
     
  10. Y2daT
    Instant PM

    Y2daT Over Powered RC
    ELiTE MEMBER

    Joined:
    Dec 25, 2013
    Messages:
    4,041
    Likes Received:
    1,064
    CreationFab - Plugs Other Receiver Bypass Adapter
    here is one for sale . if you look close you can see how its wired
    the small end goes to the rx. with only the black and white
    on the double end the servo ( or other item) plugs in to get all three wires .
    and the bec gets only the red and black wire
     
    #10 Y2daT, Oct 27, 2014
    Last edited: Oct 27, 2014
  11. HalNutt
    Instant PM

    HalNutt Studio Forums Elite
    ELiTE MEMBER

    Joined:
    Oct 29, 2016
    Messages:
    203
    Media:
    46
    Likes Received:
    86
    How do you know your esc is fried? My 3c traxxas caught fire now i know that one is done but two unsensored brushed escs cant get either to work. One lights up plygging in the main battery and powers the rx but nothing to the motor. The other doesnt do anything until i plug a battery into the rx then itll light up but still no power to the motor
     
  12. HalNutt
    Instant PM

    HalNutt Studio Forums Elite
    ELiTE MEMBER

    Joined:
    Oct 29, 2016
    Messages:
    203
    Media:
    46
    Likes Received:
    86
    Oh yea your issue isnt it BEC = Battery Elimination Circuit? So why all the plugging and playin wit the wires? Thought u were eliminating wires
     

Share This Page