1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Don't laugh but I have a problem.

Discussion in 'Newbe Help' started by Bowie2003, Feb 5, 2013.

  1. konsellaj

    konsellaj New Member

    Joined:
    Jul 4, 2013
    Messages:
    7
    Likes Received:
    0
    u could also try replacing the esc i had a verrry similar issue with a rustler before the brushless stuff came out and i got out of the hobby for a while turns out the old factory esc's for them aren't waterproffed /resistant so just a little bit of water would fry em and if its a cheaper rc it could also be a bad connection inside the electrical portion of the truck somewhere
     
  2. BRAV0

    BRAV0 New Member

    Joined:
    May 1, 2013
    Messages:
    73
    Likes Received:
    0
    EDIT: apologies, I didn't quite make it to the second page before making this post.
     
    #62 BRAV0, Jul 4, 2013
    Last edited: Jul 4, 2013
  3. kinaninja

    kinaninja New Member

    Joined:
    Jan 29, 2014
    Messages:
    47
    Likes Received:
    1
    Geez I'm having the same problem...lol I wonder what the problem was!!!! I would like to know!!!!!
     
  4. Batone76

    Batone76 New Member

    Joined:
    Jul 5, 2016
    Messages:
    1
    Likes Received:
    0
    I have the same car and issue with an unjustable slipper, the weird thing is the actual manufacturer says there is a nut that can be adjusted like any other rc car has. Im waiting for theyre email for a "picture" of this nut...
     
  5. Christopher Wiggins

    Christopher Wiggins New Member

    Joined:
    Nov 18, 2017
    Messages:
    4
    Likes Received:
    0
     
  6. Christopher Wiggins

    Christopher Wiggins New Member

    Joined:
    Nov 18, 2017
    Messages:
    4
    Likes Received:
    0
    ? The himoto bowie an iron track same truck but are the drivshafts compatible for each truck one has 96.4mm iron track an himoto 97.2mm
     

Share This Page