1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

honcho scx10 steering problem. I Cannot figure it out.

Discussion in 'Forum Suggestions' started by cheesewiz303, May 20, 2014.

  1. cheesewiz303
    Instant PM

    cheesewiz303 New Member

    Joined:
    May 20, 2014
    Messages:
    10
    Likes Received:
    0
    Hello, i have searched plenty and cannot find anything on this im tired of searching and rather just ask. Anyway, when i turn the wheels all the way in either direction i seem to have a chatter noise and my axle is jumping but only when i turn completely. When i go straight i have no problems.
    my drive shafts are aligned i made sure of that, maybe it could be the axles inside the housings? do those have to be aligned some how?
    any advice would help.
    my honcho is stock running lipo 2s and water proofed.
    like i said; its only when I steer completely in either direction.
    thanks.
     
  2. walter
    Instant PM

    walter Studio Forums Elite
    ELiTE MEMBER

    Joined:
    Jan 8, 2013
    Messages:
    3,248
    Likes Received:
    1,156
    it's the dog bone on the end of the axle and it is normal for that type of axle .
     
  3. cheesewiz303
    Instant PM

    cheesewiz303 New Member

    Joined:
    May 20, 2014
    Messages:
    10
    Likes Received:
    0
    thanks man. i thought i messed something up when i removed everything to water proof it. but seriously thanks. have a good day
     

Share This Page